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Overview of Enveloper 
Enveloper is perhaps the fanciest AND most useful Word for Windows macro on the Planet. With each 
new version, the Enveloper feature set keeps expanding to bring you more options for your printed 
envelopes. Enveloper is both powerful and easy to use.

The features and options of Enveloper include the following:

· Print POSTNET bar codes to any printer type. Place the Destination Point Bar Code (DPBC) at the 
bottom of the envelope, above the addressee, or below the addressee. It's your choice!

· Print FIM A bar codes too! It's those bars just to the left of the stamp. Best of all, you won't get the silly
Zip code not valid! message if you have a foreign address that doesn't have a bar code.

· Print logos/graphics on your envelopes.

· Use multiple return addresses (i.e., home and business addresses). You set them up and Enveloper 
remembers.

· Look up an address from within Enveloper! A quick button-click and Enveloper consults the WOPR 
Address Book utility. You can easily customize it to hook up to your favorite Phone Book Utility

· Maintain multiple customized envelopes. Each envelope may be customized for a different situation: 
envelope size, return address, note, logo, fonts, etc. Each envelope can even be customized for a 
specific printer, ensuring perfect envelopes from all your printers.

· Print merge a stack of envelopes for your Word for Windows form letters or mailings.

· Use any of the fonts you normally use in your Word for Windows documents for your printed 
envelopes. You may format the return address and the addressee in any mixture of fonts and choose 
from bold, italic or underline formatting.

· Choose from dozens of envelope Notes.

· SmartGrab! A smarter grab than the Microsoft address grabber built into Word for Windows. You can 
choose between the two. For those really tough addresses, there is a SkipLines option to have 
Enveloper grab the addressee address from a specified line number.

· Use Print Fields to send special escape codes to your printer.

· Use the Manual Edit mode to view a model of your envelope on screen before you print.

· Best of all, Enveloper is so easy to use that you can start printing envelopes today and explore 
Enveloper's more powerful features tomorrow, as you get more comfortable with how Enveloper 
works. 



What's New in Enveloper 6 
There have been significant changes made to Enveloper 6. The changes are meant to make the program
more logical and more intuitive to use. Run-time speed is increased at the sacrifice of setup and 
customization speed. But since you don't customize very often (only at first to set up your standard 
envelopes), this hopefully won't be too large a sacrifice. In fact, Enveloper 6 on Word 6 for Windows 
seems significantly faster than Enveloper 4 for Word version 2.0.

It is worth reiterating the philosophy behind Enveloper.

The philosophy behind Enveloper's design is that ALL information rest in envelope templates, except for 
the addressee, of course. 

An Envelope template can be described best as a computer model of a preprinted envelope. It contains 
the envelope size, a return address and/or a logo. The return address can be in any font style that you 
choose. An envelope template also contains a note, its font, the addressee font, and the envelope feeder 
source; it is even tailored for a specific printer.

If you regularly use multiple envelope sizes or return addresses or logos or fonts, simply create different 
envelope templates for each style. This way you just choose the envelope you want to use at run-time 
and awaaaay you go! All the correct envelope settings without any fiddling.

For example, if you use your business return address and logo for your business envelopes and your 
home return address for personal envelopes, you can create two envelope templates. At run time, simply 
select the correct envelope template and viola!

You can even build different envelopes that run on different printers! The initial installed printer 
characteristics only apply to new envelopes that you create. So you can actually change the setting on a 
per envelope basis.

To perform any customization, choose Enveloper6 Customize from the Tools menu or click on the Setup
button when running Enveloper. 

See also:
Customizing Enveloper 



What duzzit do? 
Enveloper takes advantage of Word's Frame and Style features to position and format items on the 
envelope. Based on your input, Enveloper builds envelope templates containing all the necessary frames
and macros to print picture perfect envelopes.

These envelope templates can include a graphic/logo, an envelope note, the envelope size, feeder 
source, and font selections. All envelope information resides in the envelope templates except for the 
addressee. The advantages to this scheme are numerous. If you use your business return address and 
logo for your business envelopes and your home return address for personal envelopes, you can create 
two separate envelope templates. When you run Enveloper, just select the correct envelope template 
and away you go. No more trying to switch return addresses or envelope sizes at run-time. Whether you 
always print to the same type of envelope or not, envelope templates will speed up the printing of 
envelopes and give you additional options for your printed envelope. But first things first, let's move on to 
the installation process.



Installing Enveloper 
Welcome to the next generation of WOPR and in particular, Enveloper! It's gotten a major facelift since 
version 4, but the basic concept is pretty much the same. If you can't wait to get started, glance through 
the notes in the Before You Begin section, then open up WOPRINST.DOC and double-click on the 
Installation sentence! If you've already installed Enveloper using the WOPR Installer, you don't need to 
do anything else.

See also:
Before You Begin Installing Enveloper
Installation
Complete Install and Envelope Template Conversion



Before You Begin 
If you're a user of WOPR 2.0, please make a backup of your WOPR.INI in the WINDOWS directory before 
installing. If Enveloper makes changes to your WIN.INI, the back-up will be saved in WIN.ENV.

Enveloper needs some support files when it installs. Please make sure all these files are in the same 
directory as WOPRINST.DOC. These files are:

ENVR6.DOT
ENVR6.HLP
DLLACCES.DLL
ENVR6TPL.SKE
SAMPLE6.ENV
ZIP.TTF
The installer will copy DLLACCES.DLL and ZIP.TTF to your WINDOWS/SYSTEM directory, and your 
WIN.INI may be updated if the Zip font was not installed previously. The other files will be copied to 
your envelope template directory.



Installation 
To begin installation, open WOPRINST.DOC (the WOPR Installer), and double-click the sentence at the 
top of the document. Select Enveloper 6.0 from the list on the left and click the Install button. Choose to 
install the indicated Toolbar Button, and click OK. That will bring you to the initial installation dialog box of 
Enveloper Installer.
Choose the Envelope Feed mechanism that matches your printer. If you're an Enveloper 4.0 user, the 
installer should pick up your current settings. Hopefully the icons are self-explanatory. Use the drop-down 
list to find a printer that best matches yours. You can fine-tune by selecting other Feed Method Icons, the 
FaceUp/FaceDown options, and the Reverse Landscape check-box.

Right-click on an icon to get a short list of matching printers.

Remember that the arrow in each icon indicates the feed direction, so if your envelope feeds from the 
back of the printer, stare at your printer from the back to match the setting. If your printer feeds from the 
top, then stare down at it into the feed path. 

If you're using an envelope feeder or are on a DeskJet / BubbleJet / InkJet printer, make sure the Fit Page
To Envelope box is checked.

NOTE: The settings you choose here are only for the Sample Envelope and the first envelopes you 
create. You can change these settings for any number of envelopes to support any number of printers.

NOTE: Use the <<Back button to move around the different panes in the Installation dialog boxes. Your 
settings will be preserved as you move around, but they will not be saved, and installation will not begin 
until you click the Finish button.

Click the Next>> Button to continue Installation
The following topics describe further the elements of the initial installation dialog box. The topics include:

Feed Method Icons
Printer List Box
Face Up, Face Down, Flyer Options
Reverse Landscape
Fit Page to Envelope
Feed Tray



Feed Method Icons 
These Feed Method Icons indicate the feed mechanism for your printer. Note the location of the arrow in 
the icon, then stare at your printer, looking in the direction that the envelope feeds into the printer. Match 
that up with the icon, and you've got the correct setting for your printer.

If your envelope feeds from the rear of the printer, walk around the printer and stare at it from the back. If 
it feeds from the top, get above it and stare down at it.

You can click the Right mouse button on an icon to see a short list of suggestions.

You should use the Printer List Box to make your initial selection.

See also:
Feed Tray Face Up, Face Down, Flyer Options



Printer List Box 
This is the drop-down list box right below the list of Feed Method Icons you see when Installing or 
Customizing Enveloper. Begin customizing for your printer by first choosing a printer from this list.

For obvious reasons, we can't possibly list all printers, but the most popular ones are listed and your 
printer manual will most likely indicate which one of these your printer emulates.



Face Up, Face Down, Flyer Options 
These options are available when you Install or Customize Enveloper. Choose the one that matches your
printer.

Note that the Flyer option allows you to print an envelope image on 1/3 of a letter-sized page, such that 
when you fold it up, you get a flyer that you can send out. Choose between Top, Middle, or Bottom by 
selecting the appropriate Feed Method Icon after you select this option.



Reverse Landscape 
Reverse Landscape printing can be described best as an envelope that prints with the return address 
first. Printing the return address first minimizes the chances of it being smudged. Some printers 
automatically print envelopes in this mode. If your printer prints with return address first check the 
"Reverse Landscape" box.

Other printers may be coaxed into printing in Reverse Landscape. These include printers using the PCL5 
or PostScript printer languages. If that matches your printer, also check the Reverse Landscape box. 
Enveloper will embed Print Fields (raw printer code), if necessary, to change the printer mode before 
your envelopes print.

Note that some printers naturally print envelopes in Reverse Landscape without any help from 
Enveloper, BUT only for envelope sizes it knows about! For custom sized envelopes, you may be forced 
to print in Normal Landscape or embed Print Fields. This is true for the IBM Lexmark LaserPrinters,    
Panasonic Lasers and the TI microLasers. Please check your printer manual for details.

If you have problems with this setting, try turning it OFF, and enable the Fit Page to Envelope setting.

See also:

PCL5

PostScript



Fit Page to Envelope 
If you use an Envelope Feeder, an Envelope Tray, or a DeskJet/BubbleJet printer, you may need to use 
the "Fit Page to Envelope setting. Why? Well, these devices are very picky about what they print. If 
Enveloper sends the printer an envelope image that's placed on a letter-sized page (this is the default 
behavior of Enveloper), these devices will assume that you've made a mistake and will either refuse to 
accept the input or draw extra sheets of paper through the printer.

If you use the "Fit Page to Envelope" option, Enveloper uses a paper-size that is the same size as the 
envelope. That satisfies the printer. The drawback here is that you cannot print custom sized envelopes 
with a size that is not recognized by the printer... and there are a lot of these (envelopes). Complain to 
your printer manufacturer!



Feed Tray 
This drop-down list box allows you to choose the printer source from which you'll be feeding envelopes. 
You'll see it during Installation and Customization of Enveloper.

The only caveat is that some Envelope Feeders on some printers have a non-standard setting. Consult 
your printer manual to find the specific feeder number for your printer. Enveloper includes extra settings, 
Printer Specific 6 to Printer Specific 11 for your convenience.

See also:
Face Up, Face Down, Flyer Options
Feed Method Icons



Reverse Landscape Settings 
If you chose a Reverse Landscape setup in the initial Enveloper Install dialog box to make return 
addresses print first, you'll be asked if you want to insert special printer codes to perform the trick. You 
have the following options:

PCL5 Printer
Choose this setting if your PCL5 printer does not normally print in Reverse Landscape. Enveloper will 
imbed PCL5 code in your envelopes. Printers that fall into this category are LaserJet III series and 
LaserJet 4 series printers.

PostScript Printer
You have two options for your PostScript printer. You can either choose to imbed PostScript printer codes 
or modify your WIN.INI (by adding LandScapeOrient=270) to print all landscape documents in 
Reverse Landscape.

Choose Yes in the bottom half of the dialog box to have Enveloper Install automatically modify your 
WIN.INI. This is the recommended setting.

Choose No in the bottom half of the dialog box to embed PostScript printer codes in your envelopes. The 
default printer code only works on 300 dpi printer! This is not recommended, since it requires that you 
know PostScript and Print Fields. See the Advanced Topics topic for details.

NOTE: The LandScapeOrient setting and PrintFields cancel each other out! To use the 
LandScapeOrient setting with your Enveloper4 envelopes, you must remove the Print Fields from 
those envelopes after installation completes.

Other Printer
Choose this setting if your printer normally prints in Reverse Landscape without requiring printer codes. 
Some IBM Lexmark, NEC, Panasonic, and TI Laser printers fall into this category. Please consult your 
printer manual.

NOTE: If your printer does Reverse Landscape for envelopes, you may also need the Fit Page to 
Envelope setting to convince your printer that you really are sending an envelope.

Click "Next>>" to continue Installation



Choosing Options 
In this dialog box panel, choose your envelope directory, addressee-grab method, and measurement 
units. Again, the installer should have picked up your Enveloper 4.0 settings.

If you choose the same envelope directory as Enveloper 4.0, the installer can convert all your envelopes,
placing backup in files with the .EV4 extension. If you choose a different directory, the installer will copy 
all the Enveloper 4.0 templates to the new directory before converting, allowing you to use both 
Enveloper versions with both versions of Word for Windows.

Enveloper now uses points as its internal measurements. Choosing between inches and cm just tells 
Enveloper to convert from your default units to points.

If you're installing for the first time or chose a Complete Installation when reinstalling, you can also select 
between two sets of initial envelope sizes:

US Envelope Sizes
Business Com 10 4.125 in x 9.5 in
Monarch 3.875 in x 7.5 in
Personal #6 3.625 in x 6.5 in
Size 9 3.875 in x 8.875 in
Size 11 4.5 in x 10.375 in
Size 12 4.75 in x 11.0 in
Letter-sized Flyer 3.66 in x 8.5 in

European / Metric Envelope Sizes
Business DL 11.0 cm x 22.0 cm
C5 16.2 cm x 22.9 cm
C6 11.4 cm x 16.2 cm
C65 11.4 cm x 22.9 cm
Italian 11.0 cm x 23.0 cm
Personal 11.5 cm x 16.0 cm
Letter-sized Flyer 9.9 cm x 21.0 cm

Finally, you can choose between two strategies for grabbing addresses from your letters and documents.

Microsoft Grab
SmartGrab

The Microsoft Grab is much faster, so you may want to start with that. But if your address lines are 
separated by new line characters (Shift+Enter), the Microsoft Grab method will still fail! Choose 
SmartGrab if that's your situation. If Enveloper does have trouble grabbing your address, choose 
Enveloper6 Customize from the Tools menu to change the grab method setting.

Click "Next>>" to continue Installation



Complete Install and Envelope Conversion 
If this is the first time you've installed Enveloper 6.0, choose the "Complete Installation". Enter your first
Return Address in the Text Box. Later you can add additional Return Addresses by using Enveloper6 
Customize.

If you're an Enveloper 4.0 user, you won't see the Return Address box. Rather, choose whether or not to 
convert your Enveloper 4.0 envelopes. The Enveloper Installer will back up your original envelopes 
using the .EV4 extension. Keep those in a safe place just in case. If you choose not to convert, only the 
Sample Envelope will be listed for Enveloper 6.0.

If you have a lot of envelopes, the conversion may take a few minutes. So go grab a cup of coffee!

Click "Finish" to proceed with Installation



Finishing Up 
The Enveloper 6.0 installation will create a completely new section in WOPR.INI. It will not touch your 
Enveloper 4.0 settings. When you are satisfied with the operation of Enveloper 6.0, you can manually 
delete all of Enveloper 4.0 settings from WOPR.INI using an ASCII text editor.

After your new settings are saved, you'll be asked whether or not to install the Zip font. Please answer 
Yes. You can also print a Sample Envelope before conversion starts.

After you've finished installing WOPR utilities, choose Enveloper6 Customize from the Tools menu to 
customize Enveloper or click on the Envelope Tool to try it out! ENJOY!

See also:
Customizing Enveloper



Assigning a Key Combination to Enveloper 
If you'd like, you can assign a key combination such as Ctrl+E or Ctrl+Shift+E to the Enveloper and 
EnveloperCustomize macros. To assign a key to the Enveloper macro, do the following:

1. From the Tools menu choose Customize. Select the Keyboard tab.

2. In the "Save Changes In" list (lower right), choose either ENVR6.DOT or WOPR.DOT to save the 
shortcut keys in one of the WOPR Add-Ins.

3. From the Categories list box, select Macros.

4. From the Macros list box, choose the Enveloper or EnveloperCustomize macro.    

5. In the "Press New Shortcut Key" text box, just type Ctrl+E (hold down the Ctrl key then press the E 
key) or any other combination you want. Word for Windows version 6.0 even allows you to assign a 
two key combination, such as Ctrl+E, C.

6. Once you have selected a key combination for the Enveloper macro, choose the Assign button to 
add the key combination.

7. Choose the Close button to return to the Word for Windows editing window.

If you want to remove Enveloper from your system (we hope you won't want to), open the 
WOPRINST.DOC document in your WOPR directory and run Setup.



Creating a New Envelope 
There are two way you can go about creating and customizing new envelope templates for Enveloper.

Basing a New Envelope on an Existing Envelope
Creating an Envelope Template From Scratch



Basing a New Envelope on an Existing Envelope 

Once you have created one envelope template it is easy to create new ones based on an existing 
templates. For example, if you've already created a business envelope for domestic mail and want 
another template for foreign mail that includes the note, "Air Mail", you can base the new template on the 
existing business envelope and just change the Envelope Note. Or if you need to print to monarch sized 
envelopes, you can base the monarch envelope template on your existing Com-10 Business envelope 
and then just change the envelope size. 

To base a new template on an existing template, do the following:

1. From the Tools menu choose Enveloper6 Customize.

2. Select the template you wish to base the new template on. For this example, select "Sample 
Envelope" from the list of Envelope Descriptions.

3. Choose the New button.

4. In the Envelope Description text field of the following dialog box, enter "Standard Business Com10". 
Typically, you should give the template a descriptive name that you can later identify when running 
Enveloper.

5. There is also a list of existing template files ending with the .ENV file extension along with a proposed
filename for your new template (i.e. TEMP12.ENV). Change the suggested name to BUSINESS.ENV. 
If you do not enter a file extension, .ENV will be appended.

6. Choose the OK button and Enveloper will build a new template with the same settings as the original 
template. You can also choose the <<Back button to return to the previous envelope template list for 
review.

Once the new template is created, Enveloper will bring you to the main customization dialog box. The top
box displays the Envelope Description that you entered previously. The command buttons in this dialog 
are used to customize the envelope template. The Envelope Size box displays the selected size for this 
envelope (size of the original envelope). The current return address and envelope note is also listed.

To perform any changes, start at Step 5 of the following topic Creating an Envelope From Scratch.



Creating an Envelope From Scratch 

The following information details the steps involved in creating a new business sized envelope with the 
description "New Standard Business". This template is created from "scratch" meaning it is not based on 
another envelope template.

1. Run the Enveloper Customization macro by choosing Enveloper6 Customize from the Tools menu.

2. Choose "(none)" from the Envelope Description list and choose the New button.    

3. You will be prompted for a description and a filename for the new template. For this example, type 
"New Standard Business" in the Envelope Description box. Type COM10.ENV for the filename and 
click the OK button.

Note: In the background you will see documents being opened and manipulated as Enveloper begins
to build the envelope template file.

4. Enveloper will then bring you to the main customization dialog box. The command buttons in this 
dialog are used to customize the envelope template. The top box displays the Envelope Description 
that you entered previously. The Envelope Size box displays the selected size for envelope. The 
default return address and envelope note are also listed.

5. Choose an envelope size. For this example, click on the Envelope Size drop-down list box and 
choose Business Com 10 - 4.125 in x 9.5 in (European / Metric users should choose 
Business DL - 11.0 cm x 22.0 cm) Click the OK button.

6. If your return address does not appear or is not accurate, click the Return Addr button to change the 
return address information. Choose the New button to create a new return address or select an 
address and choose the Edit button to edit the current return address information. Once you have 
added or edited the return address, click the Add or Change button. 

7. Click the "Use for Envelope" button to apply the selected return address to the envelope. Click 
<<Back to get back to the main customization dialog box for additional changes. (You can also click 
the Save & Exit button to end and save the editing for the envelope.)

8. If you would like to change the Envelope Note, simply choose one from the drop-down list. 

To add or edit Envelope Notes, click the Note button. Choose the New button to add a new note or 
choose the Edit button to change the text of the selected envelope note. Click the <<Back button to 
get back to the main customization dialog.

9. Choose the Fonts & Logo button to change the font selections for the envelope text. There are five 
envelope items that you can choose to configure: Return Address Line 1, Return Address Others, 
Addressee Line 1, Addressee Others, or Envelope Note. When you select one of these five 
buttons, you will be presented with the Format Font dialog box for the selected styles. Choose the 
<<Back button when customization is complete.

Note: The Return Address Others style is based on Return Address Line 1. As a result, changing 
the character formatting for Return Address Line 1 will also change the formatting for Return 
Address Others. The same relationship exists between Addressee Line 1 and Addressee Others 
styles. 

10. The Envelope Source drop-down list box near the bottom of the dialog lists the currently selected 
envelope feed source. If this selection is not correct, change it. 

11. Finally, choose the Save & Exit button from the main customize dialog. This will save all the changes 
that you have made to your envelope template file. Select the new envelope description and choose 
Set as Default to set the new template as the default envelope template. Click OK to finish 
customizing.

The above steps introduces the basic procedure for Enveloper customization. There are, of course, more
features to each of the separate dialog boxes than you've encountered. If you have questions about a 



particular part of Enveloper (such as POSTNET bar codes), jump to the Customizing Enveloper topic.



Using Enveloper 
Once installed there are three ways to run the Enveloper macro:

1. Click on the Envelope button on the WOPR Toolbar.

2. From the Tools menu choose Enveloper6 

3. Press the key combination that you have assigned for Enveloper. See Assigning a Key Combination 
to Enveloper for more information.

When you do one of the above operations, Enveloper will try to grab an addressee from the active 
document window (the idea here is that after you write a letter, you would run Enveloper to print the 
envelope). Enveloper provides three different addressee grab modes for you to choose from: Microsoft's 
addressee grab, SmartGrab, or SkipLines. Each has its advantages and disadvantages. See the 
Addressee Grab Method topic for more information.

Enveloper also provides Phone Book and Find Zip buttons that allow you to access a Phone Book 
Utility and Zip Code Utility.

All you need is to write a couple of functions that grab the information from your utility and return a string 
to Enveloper that represents the updated address. By default, the Phone Book button is hooked into the 
nifty Address Book Lite utility that comes with WOPR. You can look at the example in the EnvHooks 
macro to adapt it for your Phone Book utility or Personal Information Manager (PIM).

Unfortunately, as of this writing, we were not able to find a reasonable Zip Code utility (in cost and ease of
use) that we can hook into Enveloper. Nevertheless the hook is there so you may create the hooks 
yourself, or we can provide an easy upgrade when we do find that utility.

See also:
Enveloper User Interface



Enveloper User Interface 

After grabbing an addressee, Enveloper displays the addressee information for possible changes. You 
can accept the grabbed addressee or type in an entirely new addressee. You'll see grayed out items 
reserved for merging when you run it on a main merge document. (The good news is that performing 
Enveloper Merge is now as simple as using Enveloper itself!)

Choose an envelope from the drop-down list. Your default one is chosen initially. (If this is the first time 
you have run Enveloper or you have not created templates to date, then there will be just one template 
named "Sample Envelope".) With the desired envelope selected, you can choose the Print button to 
print the envelope without any further interruption.    

If the "Print Bar Code" box is marked, then the Zip Code in the addressee will be used to print a bar code
that conforms to the U.S. Postal Service's POSTNET standards (see POSTNET Bar Codes, for more 
information on Postal Bar Codes). If your address includes a Zip+4 Code, then the Destination Point Bar 
Code (DPBC) will be printed. Use the "Print FIM A" check box to indicate whether or not to print the FIM 
bar code (the one to the left of the stamp).

Click on Note to temporarily change the note for this particular envelope. The addressee area changes to 
the list of notes. You can choose one from the list or type in a new one. Note that the button text also 
changes to "Addressee". Click on it again, and you get the addressee back.

If you choose the Manual Edit button, you'll be dumped into the actual envelope document for manual 
editing. An additional Toolbar will pop up to help you change the fonts and logo size. You can also print 
from it. You can even choose from your list of Return Addresses and Notes. To get back to the main 
Enveloper screen, click Cancel. Print before you click on Cancel, or you'll lose the envelope!

Clicking on the Setup button brings you to the customization section.

See also:
Customizing Enveloper
Creating an Envelope Template From Scratch



Enveloper Merge 

The key elements you need before merging envelopes are as follows:

1. A Data File that includes your list of addresses.

2. A Main Merge Document, representing a letter model, that specifies where each component from the 
Data File should be placed.

If you have a data document (and header document) attached, Enveloper Merge will pick up the same 
settings. If you have search criteria defined, they will also be picked up. So theoretically, after you finish 
your Word merge letter, all you have to do is click on the Envelope Tool, then the Print/Merge button. A 
new merge document will be created based on the selected envelope. You will then be presented with the
standard merge dialog box to merge to a printer or document, to select a range change query options.... 
Instead of Print/Merge, you can also choose "Add to Document" to attach an envelope to your main 
merge document.

The only things you might want to change are the drop-down lists to choose the merge field that contains 
the numbered street address and the zip code. This will ensure that the bar codes are generated 
correctly. You can also modify the merge address by choosing additional fields from the "Append Field" 
drop-down list; as its name indicates, you an only append to the end of the displayed address.

See also:
Creating a Main Merge Document
Creating a Merge Data File
Merging an Envelope



Creating a Merge Data File 

Word for Windows 6.0 can accept quite a few database formats as the data file of a merge document, 
ranging from comma-delimited lists to Excel tables or Microsoft Access data. If you already have a data 
file, you can skip this section. This section describes a quick way of creating a data file, using the merge 
engine built into Word for Windows 6.0.

1. From the File menu choose New and click the OK button.

2. From the Tools menu choose Mail Merge.

3. Click on the Create button and select Form Letters.

4. Click on Get Data, select Create Data Source and click OK.

5. Supply a file name for the data file. You can use MRGDATA.DOC or ADDRESS.DOC.

6. Click on the Edit Data Source button.

7. You're now presented with the Data Form. The number at the bottom indicates which entry is 
showing, and you can use the arrows to move back and forth. There is only one blank entry now.

Just enter the data, using the <TAB> and Shift+<TAB> keys to move around. Click on Add New to 
add another entry. When you're done entering data, click on OK.

That's it! You're now placed in the main merge document. It should be blank. To enter or edit more data, 
just click the right-most button in the Mail Merge Toolbar. 
See also:
Creating a Main Merge Document
Merging an Envelope



Creating a Main Merge Document 

Mail Merging in Word for Windows has never been easier. Again if you've already figured out how to 
create a main merge document, you can skip this section. 

1. If you've already followed the steps in the previous section, Creating a Merge Data File, you can skip 
to step 4. Otherwise, create a new document and select Mail Merge from the Tools menu.

2. Click on Create and select Form Letter. Click on Active Window.

3. Click on Get Data and choose Open Data Source. Click on Edit Main Document.
4. Now you're staring at a blank main merge document. Simply type in the elements you would include 

in a normal letter. The only difference is for the address block, you would use merge fields. These 
fields get filled in with the data from the data file when you perform the merge.

Just as an example, press the <Enter> key a few times to insert some blank lines.

5. Click on the "Insert Merge Field" on the Mail Merge Toolbar and you'll see al list of the merge fields 
you can use from your data file. Choose Title. This action inserts <<Title>> into the document. 
After merging, that Title field will be replaced by Mr., Ms., Dr., or whatever information you've entered 
in the data file.

6. Press the <SpaceBar> to insert a space, then click on the "Insert Merge Field" button again and 
choose FirstName. Insert another space and choose LastName from the Insert Merge Field button. 
Now press <Enter> to begin a new line.

7. In this manner, complete the address block to look like the following:
«Title» «FirstName» «LastName»
«Company»
«Address1»
«Address2»
«City», «State» «PostalCode»
«Country»

8. Enter a couple more blank lines, and type "Dear". Press the spacebar and then click the Insert 
Merge Field button again. Choose FirstName. Type a comma.

Congratulations! You've completed your first Main Merge document! What? not quite yet? Oh yeah, you 
want to see the result!

Okay. On the Mail Merge Toolbar, find the icon that merges to a document. It's the button just to the right
of the one the check mark button. Move your mouse cursor over the button and you should see the 
description pop up: Merge to New Document. Click this Toolbar button.

Now it's time for congratulations. You should have a new document that contains multiple copies of your 
letter, each with a different address, grabbed from your data file!

See also:
Merging an Envelope
Creating a Merge Data File



Merging an Envelope 

Once you have the Main Merge document and the Data file set up, merging an envelope using 
Enveloper is a snap. 

1. Activate the window containing the Main Merge document. If it's not open, use File Open.

2. Make sure the "View Merge Data" mode is OFF: Click the ABC button on the Mail Merge Toolbar 
(turn this mode ON when you want to print just one record).

3. Click on the Envelope tool from the WOPR Toolbar. Enveloper will pick up the address block 
containing your merge fields.

4. Note that the list boxes marked "Field containing street address" and "Field containing Zip code" 
should select the correct fields. Proper selection ensures that the bar codes will be generated 
correctly.

5. Click on the Print/Merge button.

6. You'll be presented with the standard Merge interface. You can choose the destination of the merge in
the list box at the top left. You can choose New Document or Printer. Choose New Document for 
this example.

7. Click on the Merge button to complete the merge. When finished, you'll end up with two additional 
documents: one containing all the resulting envelopes and the other a main envelope merge 
document.

If you don't need to print a merge letter and only need to merge envelopes for, say Christmas or 
Weddings, you can still follow the procedure in this section. The main merge document should just 
contain the address block:

«Title» «FirstName» «LastName»
«Company»
«Address1»
«Address2»
«City», «State» «PostalCode»
«Country»

That wasn't so bad, was it?

See also:
Creating a Main Merge Document
Creating a Merge Data File



Customizing Enveloper 
Choosing Enveloper6 Customize from the Tools menu allows you to customize the following features of 
Enveloper: 

General Preference Settings
From the Tools menu, choose Enveloper6 Customize. Click on the Settings>> button to get to the 
dialog for changing preferences. Use the <<Back button to move around the different panes in the 
Customization dialog boxes. Your settings will be preserved as you move around, but they will not be 
saved until you click the OK button.

User Level
Addressee Grab Method
POSTNET Bar Code Options
ALL CAPS Addressee

Envelope-Specific Settings
From the Tools menu choose Enveloper6 Customize. Choosing New or Edit brings you to the main 
customization dialog box where you can make changes to the Envelope-Specific Settings.

Envelope Description
Envelope Size
Return Address
Enveloper Fonts
Logo
Envelope Note
Envelope Feed Tray
Printer Feeder Settings
Zip Bar Code Settings
Print Field

See also:
Basing a New Envelope on an Existing Envelope
Creating an Envelope Template From Scratch



User Level 
Choose from three different user levels depending upon your familiarity with Enveloper.

Beginner is the default setting for Enveloper. With this setting there will be warning messages when 
printing manual-feed envelopes and when entering the Manual Edit mode.

Intermediate is what you want if you grow tired of these messages

Expert mode will eliminate all dialog boxes. If the Expert mode is employed and you click the envelope 
button, the envelopes will be printed without any intervention on your part. Enveloper will use the default 
template and the default grabbed addressee to print the envelope.

An alternative to the Expert mode, would be to create a new macro called something like 
QwikEnveloper. This macro would contain a single line, similar to the following:

Sub Main
Enveloper6.Enveloper(1,"c:\winword\env\com10.env")
End Sub
The above macro will run Enveloper without prompts and will use the envelope template named C:\
WINWORD\ENV\COM10.ENV; the full path name for your envelope template should be used.

Using a QwikEnveloper macro will allow you to have both the interactive Enveloper and a fully-
automated Enveloper. This method also allows you to change the default Enveloper template without 
affecting the envelope template used by QwikEnveloper.



Addressee Grab Method 
Enveloper provides three different options for "grabbing" the addressee information from a Word for 
Windows document: 

Microsoft's addressee grab

SmartGrab

SkipLines

Each method has its advantages and disadvantages. After reading through the explanations of the three 
grab options you can decide which will work best for you.

After grabbing an addressee, Enveloper places the addressee information in an editable dialog box. You 
can either accept the grabbed addressee or type in an entirely new addressee on-the-fly. If the grab 
method fails to grab an address, the addressee text box will be blank. You can type the address in 
manually.

Choose Enveloper6 Customize from the Tools menu, the click on the Settings>> button to get to the 
dialog for changing preferences.

See also:
Customizing Enveloper
Microsoft's addressee grab
SmartGrab
SkipLines



Microsoft's addressee grab 
This is the grab routine used by the Word for Windows internal envelope feature. This method is the 
fastest of the three, but not always accurate. In particular, this method will not grab your address if the 
lines are separated by a new line character (Shift+<Enter>) rather than a paragraph mark (<Enter>).

Nevertheless, because Microsoft's addressee grab is the fastest, it is the default setting for Enveloper. Its
algorithm works as follows:

1. If you have select document text, the selected text will be used as the addressee.

2. If you have a bookmark called EnvelopeAddress or NameAddress, the contents of that bookmark 
will be used for the addressee.

3. If you have left justified text that is 3 to 5 lines long, none over 58 characters, it will be used as the 
addressee. Tabs within the address are not allowed; everything after the Tab is truncated.



SmartGrab 
SmartGrab performs similarly to the Word for Windows grab routine, but is slower since it uses 
WordBasic commands to search for the addressee. This method for grabbing addressee information 
does, however, result in fewer incorrect "grabs". If you find that Microsoft's addressee grab is not working 
for you try the SmartGrab option. The algorithm used by SmartGrab is as follows:

1. If you've selected a block of text Enveloper grabs the selected text and uses it as the addressee. The
selection must be more than 10 characters long, and long addresses will be truncated to 215 
characters.

2. If you have a defined bookmark called NameAddress (which is a common name in the Word for 
Windows templates), Enveloper will grab the bookmark text as the addressee (again, truncated at 
215 characters).

3. If you have a defined bookmark called EnvelopeAddress (which is the name used by Microsoft's 
Envelope routine), Enveloper will grab everything in that bookmark as the addressee.

4. And finally as a last resort, the text meeting the following criteria will be grabbed:

Left-justified

Three or more non-blank text lines that do not include a picture nor are part of a Word for Windows 
table.



SkipLines 
SkipLines is the most rigid of the three methods. The idea here is that you indicate how many lines you 
want Enveloper to skip (from the beginning of file) before Enveloper starts to look for non-blank text to 
be used as the addressee. SkipLines is used only if steps 1 through 3 of SmartGrab fail.



Bar Code Options 
There are two check boxes you can choose to indicate whether or not bar codes should be printed on 
your envelopes. Check the "Print POSTNET Bar Code" box if you want the bar codes printed. Check the 
"Print FIM A Bar Code" box if you want the FIM A bar code (it's the thing just to the left of the stamp.) 
The default is to check both boxes.

Note that if your addressee does not contain an US address with a zip code, no bar codes will be printed 
regardless of these settings.

If the Print POSTNET Bar Code box is not check, the Print FIM A Bar Code box is disabled. Its setting 
has no effect.

To find out more about POSTNET bar codes, jump in the POSTNET Bar Codes topic.



ALL CAPS Addressee 
According to the official USPS specs, it's best if the addressee is in ALL CAPS and a non-serif font, such 
as Arial, Helvetica, etc. (Yecch!) So.....here is a setting to do that. Check the box marked "Addressee in 
ALL CAPS" in the Settings section of Enveloper6 Customize.

Technically, abbreviations should also be used, like CIR instead of Circle, FLS instead of Falls, BSMT 
instead of Basement, etc. Well......Enveloper's not going to do that for you. Sorry.

The default for this setting is OFF.

See also:
Customizing Enveloper



Envelope-Specific Settings 
To change envelope-specific settings, such as the Return Address, fonts, or logo, do the following:

1. From the Tools menu choose Enveloper6 Customize.

2. Select an envelope from the Envelope Description List, and click Edit. This will bring you to the Main 
Customization Dialog Box.

As you make changes to various parts of the envelope, you'll be presented with different "panes" of the 
dialog box. You can press the <<Back button from these secondary panes to get back to this Main 
Customization Dialog Box; the changes you've made in the secondary panes will be preserved. To save 
the changes to the envelope, click the Save & Exit button. This will also exit the Customization Dialog 
Box and take you back to the Envelope Description List. Note that you can click Save & Exit from any of 
the panes to save all changes. If you click Cancel, all changes will be discarded and you'll be presented 
with the Envelope Description List again.

You can also click on "Test Print" to print a sample of the envelope or "Manual Edit" to enter Manual Edit
mode.

See also:
Envelope Description
Envelope Size
Return Address
Enveloper Fonts
Logo
Envelope Note
Envelope Feed Tray
Printer Feeder Settings
Zip Bar Code Settings
Print Field



Envelope Description 
The Envelope Description is the text assigned to explain the envelope template. This might be something 
as generic as "Personal Envelopes" and "Business Envelopes" or something more specific like "Monarch 
Bulk Mailing Envelopes" or "Special Festive Envelopes on DeskJet".

To change the Envelope Description that now appears at the top of the Main Customize dialog, just type 
in the text box.



Envelope Size 
The Envelope Size is the physical dimensions for your envelope (height and width). To change the 
envelope size for the current envelope, just choose a size from the "Envelope Size" drop-down list box.

What? Can't find one that matches? Click on the Size button to create new envelope sizes. Click on the 
New button to create a new envelope size description and dimension. In the "Envelope Size Description" 
text box, enter text to describe the size and/or type of envelope you are using. An example of this might 
be Business Com 10 - 4.125 in x 9.5 in. This type of description is not mandatory, but is a 
helpful when you must choose the size from the "Envelope Size" drop-down list box of the Main 
Customization Dialog Box. 

The two smaller text boxes are for the actual height and width of the physical envelope. You will want to 
measure your envelope and enter the appropriate values. When you're satisfied, click Add. This will add 
the new envelope size to the end of the list. If you decide not to add a new size, click No Change. After 
adding a new size, you may select the new size from the list and choose "Use for Envelope" to use this 
size for the current envelope and get back to the Main Customization Dialog Box.

In addition to the New size, there are the Edit and Delete buttons to allow you to edit an existing 
envelope size, or to remove the selected size from the envelope-size list. If you edit an existing envelope 
size, click Change to apply the change or No Change to discard the edits.

You can also set a default envelope size for new envelopes created from scratch. To set a size as the 
default, select it and click the Set as Default button.

Note: Changing the envelope size may change your logo and return address placements.



Return Address 
The return address for your envelope is displayed in the "Return Address" box. Choose the Return Addr 
button to select another return address or to change and add new return addresses.

To choose a return address for the envelope, select one from the list and click the Use for Envelope 
button. If you do not need Enveloper to print a return address, as in the case of pre-printed envelopes, 
choose "(none)" from the Return Addresses list.

The process of changing return addresses is very similar to that of changing envelope sizes:    

To edit an address, select the address from the list and click the Edit button.

To add a new address, choose the New button.    

Choose the Delete button to delete the selected return address.    

Choosing the Edit or New button will allow you to change or enter the return address in the bottom half of
the dialog box. Click on Change or Add to apply the changes, or No Change to discard them.

The current default address is listed at the bottom of the dialog box. To set the default address, select an 
address from the Return Addresses list and click the Save as Default button.



Invitation Envelopes 
Envelopes for invitations often have the return address printed on the flap... on the back side of the 
envelope. We really wanted to help out here, but we couldn't think of a way to do it in one pass through 
the printer. We could tell you to open the flap so we can print the return address, upside-down, on the 
flap, but we didn't think your printer would appreciate that glue going through your rollers....

As a compromise, Enveloper provides a check box marked "Horiz Center Return Address". This will 
allow you to define a separate envelope template to print on the back flat, horizontally centered. This 
allows you to turn all your envelopes over to print just the return address with NO addressee or bar codes.
Then turn them over again to merge your addresses to the envelope, using another envelope template for
the front side (no return address).



Enveloper Fonts 
To change your envelope fonts, do the following:

1. From the Tools menu choose Enveloper6 Customize.

2. Select an Envelope template description and choose the Edit button.

3. Choose the Fonts & Logo button.

Enveloper maintains 5 different font styles for your envelope:

EnvAddressee For the first line of the addressee

EnvAddresseeRest For all other lines of the addressee

EnvRetAddr For the first line of the return address

EnvRetAddrRest For all other lines of the return address

EnvNote For the envelope note

You can change these fonts by clicking on Enveloper's convenient command buttons.

From the Main Customize Dialog Box, click on the Fonts & Logo button. Choose any of the five button in 
the top half of the dialog box to change the fonts. You'll be presented with the standard Word for Windows
Font dialog box.

Choose from any of the font attributes in the dialog box (font name, font size, bold, italics...) and look for 
the result in the lower right preview image. Change as many attributes as you like and select the OK 
button. You then can customize another envelope element or choose the <<Back button to return to the 
Main Customize Dialog Box.



Envelope Logos 
Although you can add any graphics or additional text to your envelopes, Enveloper can help you manage
one logo for each of your custom envelopes. Click on the Fonts & Logo button in the Main Customize 
Dialog Box. If the envelope contains a logo being managed by Enveloper, the Logo "Filename" text box 
will contain the filename of the logo; otherwise, it will be blank.

Note: Whenever you perform a logo operation, all envelope item positions will be reset to predetermined 
locations. As a result you may need to use the Manual Edit Mode to fine tune the placement of items on 
your envelope.

See also:
Insert or Replace Logos/Graphics



Insert or Replace 
To add a logo/graphic on your envelopes, do the following:

1. From the Tools menu choose Enveloper6 Customize.

2. Select an Envelope template description and choose the Edit button.

3. Choose the Fonts & Logo button/

4. Choose the Insert or Replace button.

5. The Word for Windows' Picture dialog will pop up asking you to choose a graphics file. To limit your 
file search choose the type of graphic you will be inserting from the "List Files of Type" drop-down list 
box. Click on the Preview Picture button to see a preview. After selecting a logo file, click OK.

6. You will then be prompted for the logo size. The full-size dimensions are listed in the text boxes. Make
any changes you like. Click on the Reset to 100% button to reset the dimensions to the full-sized 
picture.

7. Choose the Logo Position for the logo. The two options are as follows:

Left of Return Address
Above Return Address

8. Click OK to apply the changes. Click <<Back to return to the Main Customize Dialog Box.

See also:

Resizing, Repositioning, or Deleting Logos



Resizing, Repositioning or Deleting Logos    
To resize or move your envelope logo, do the following:

1. From the Tools menu choose Enveloper6 Customize.

2. Select an Envelope template description and choose the Edit button.

3. Choose the Fonts & Logo button.

4. Choose Resize or Reposition button.

Enter the appropriate dimensions for the logo. Click on the Reset to 100% button to reset the dimensions 
to the full-sized picture. Choose a position for the logo (left or above) and when satisfied, click the OK 
button and then <<Back to get back to the Main Customize Dialog Box.

Finally, you can remove an existing logo from an envelope template by choosing the Delete button.

1. From the Tools menu choose Enveloper6 Customize.

2. Select an Envelope template description and choose the Edit button.

3. Choose the Fonts & Logo button.

4. Choose Delete button.

See also:
Envelope Logos
Insert or Replace Logos/Graphics



Envelope Note 
Enveloper lets you select a note to place on your envelopes. From the Main Customize Dialog Box, just 
select a note from the "Envelope Note" drop-down list box. Choose "(none)" for a blank note. If you do 
not find a note to your liking, click on the Note button.

The process of changing the envelope note is very similar to that of changing envelope sizes and return 
addresses:    

To edit a note, select the note from the list and click the Edit button.

To add a new note, choose the New button.    

Choose the Delete button to delete the selected note.    

Choosing the Edit or New button will allow you to change or enter the note in the bottom half of the dialog
box. Click on Change or Add to apply the changes, or No Change to discard them.

The current default note is listed at the bottom of the dialog. To set the default note, select an one from 
the Envelope Note list and click the Save as Default button.

Clicking on "Use for Envelope" will use the selected note for the current envelope and return you to the 
Main Customization Dialog Box.

Like other envelope elements, the position of the Note can be manipulated in the Enveloper Manual Edit
Mode (see Manual Editing).



Envelope Feed Tray 
Choose the feed tray for your envelope from the "Envelope Feed Tray" drop-down list box in the Main 
Customization Dialog Box. Click on the Set Default Tray button to set the selected tray as the default for 
new envelopes created from scratch.

Different envelope template may use different envelope sources. For example, if you have a dedicated 
envelope feeder for your business envelopes, you can configure your business envelope template for 
"Envelope Tray". If you hand-feed your personal envelopes, you would configure your personal envelope 
template for "Manual Feed". 

Note: Some special printers and printer drivers have feeders that require you to know the specific feeder 
number. Consult your printer manual for this number and choose one of the special feeder numbers up to 
eleven (Printer Specific 6 to Printer Specific 11).



Printer Feeder Settings 
There are a lot of printers out there, and you need to let Enveloper know which type you have so it can 
figure out how to place the envelope image correctly. These printer-specific settings are stored with each 
envelope template, so you can customize different templates for different printers.

For example, if you have a DeskJet and a laser printer that you use to print envelopes, you can make 
separate envelope templates, each tailored to its own printer. When you run Enveloper, just choose the 
envelope template that matches the currently selected printer.

To change the Printer Feeder Settings, do the following:

1. From the Tools menu choose Enveloper6 Customize.

2. Select an Envelope template description and choose the Edit button.

3. Choose the Printer & Zip Settings button.

4. Select the options you would like for your envelope template and then click the <<Back button to 
return to the Main Customization Dialog Box to make other customizations, or click the Save & Exit 
button to save all the changes to the envelope.

See also:
Feed Method
Fit Page to Envelope
Minimum Margins
Zip Bar Code Settings



Feed Method 
You may change the printer feed characteristics of individual envelopes to match a particular printer. 
Select the icon that matches the feed characteristics of your printer. To get started, choose a printer from 
the drop-down list that closely matches your printer. You can also point the mouse cursor at an icon and 
click the right mouse button to get a hint.

Click on the Set as Default button to make the selected settings apply to new envelopes created from 
scratch.

Check the Reverse Landscape button to minimize smudging by printing the return address first. This 
setting requires that you have a printer that can support this mode. If you have a printer using the PCL5 
printer language (LaserJet III and LaserJet 4 and compatible) or a PostScript printer, then you can use 
this mode.

Enveloper uses Print Fields to support Reverse Landscape on some printers. If you find that your return 
address is not printing first, check the Print Field button to make sure an appropriate print field is selected.
Jump to the Print Fields topic for more information on Print Fields.

See also:
Fit Page to Envelope
Minimum Margins
Zip Bar Code Settings



Fit Page To Envelope
Choosing the "Fit Page to Envelope" check box will tell Enveloper to use a page size that matches that 
of the envelope. This is important if you're using an envelope tray or envelope feeder. You will also need 
this setting for DeskJets.

Enveloper normally creates envelopes using a letter-sized page to ensure that the feed position of the 
envelope will remain consistent regardless of the envelope size. This also allows you to create custom-
sized envelopes not supported by the printer. Unfortunately, some printers are too smart (or too dumb, 
depending on your point of view); they will refuse to accept a letter-sized page when they are set up to 
accept an envelope. As a result, you won't be able to print custom-sized envelopes on these printers. 
(Hey, complain to the printer manufacturer!)

Click on the Set as Default button to make the selected settings apply to new envelopes created from 
scratch.



Minimum Margins
Most printers cannot print to the edges of a page. There are usually minimum margins required by each 
printer driver. Enveloper attempts to maintain margins that will satisfy most printers. If you find that your 
printer driver is giving you warning messages, you might want to change the minimum margins settings 
until the messages go away.

You might also want to change the top margin value to get your return address printed closer to, or farther
from, the envelope edge; this is especially true for portrait mode printers.

To find the proper margin settings for your printer:

1. Open a new document

2. Choose Tools, Macro... from the menu. Make sure the Macros Available In list indicates All Active 
Templates.

3. Select WOPRMinMargins from the list. Click Run.

4. Choose Portrait or Landscape, which ever matches how your printer prints envelopes. Choose 
Current Printer Size and click OK.

5. Make a note of the minimum margins, because we need to register them with Enveloper.

6. If you use Fit Page to Envelope setting for your envelopes, also try the above by using Com10 size 
setting.

Make a note of both settings to try. WinWord 6.0 has a bug in that it always uses the first set of minimum 
margins (step 4), when it should be using the second set (step 6) for envelope-sized documents. You may
need to mix the two sets of numbers by choose the larger value in each dimension to make both 
WinWord and your printer happy.

Back in Enveloper6 Customize, click the Printer & Zip Settings button from the Main Customization 
Dialog Box and enter the minimum margins values.

Click <<Back to return to the Main Customization Dialog Box to make other changes or Save & Exit to 
save all changes to the envelope.

Click on the Set as Default button to make these settings apply to new envelopes created from 
scratch.



Zip Bar Code Settings 
Enveloper allows you to place the POSTNET bar code in three accepted locations:

At the bottom of the envelope
Above the addressee
Below the addressee

Click on the Printer & Zip Settings button from the Main Customization Dialog Box and choose your 
setting. Click <<Back to return to the Main Customization Dialog Box to make other changes or Save & 
Exit to save all changes to the envelope.

If you choose to print the bar codes at the bottom of the envelope, you can fine-tune the position to make 
it print correctly on your printer. The next page, USPS Requirements and Bar Code Position gives the 
official specs.



USPS Requirements and Bar Code Position 
The United States Postal Service has a formal requirement for the position of the postal bar code on an 
envelope.    

Vertical Placement: The distance from the bottom of the printed bar code to the bottom of the envelope 
should be 1/4 inch plus or minus 1/16 of an inch.    

Horizontal Placement: Measure the distance from the leftmost printed bar code to the right edge of the 
envelope. This distance should be between 3.25 and 4.0 inches.

If your sample envelope with a printed bar code does not comply to the above requirements, you may 
need to customize the placement of the printed bar code. Click on the Printer & Zip Settings button from
the Main Customization Dialog Box to bring up the bar code position settings. The default positions are:

Horizontal Placement: 288pt or 4 inches from the first bar to the right edge of the envelope.

Vertical Placement: 30pt or approximately .5" from the top of the first bar to the bottom edge of the 
envelope.

The units are in points with 72pts = 1 inch and 28.35pts = 1 cm.      

Change the settings as needed or click on the Reset button to return the settings to the default values.

Click <<Back to return to the Main Customization Dialog Box to make other changes or Save & Exit to 
save all changes to the envelope. Click on the Set as Default button to make these settings apply to new 
envelopes created from scratch.



Print Field 
Enveloper allows printer codes to be imbedded in an envelope template to directly control printer actions.
This is how Reverse Landscape is performed for some printers. It can even correct for faulty printer 
drivers, such as the DJ550C driver, that fail to enable Envelope Feed. Most users need not be concerned 
with this feature, but if you are intrigued jump to the Print Fields topic.

Note that some printers drivers cannot accept printer codes. Among these is the Windows Printing 
System (WPS). If you're using the WPS, it means that you cannot print envelopes in Reverse Landscape.

To assign a Print Field to your envelope, 

1. Choose Tools, Enveloper6 Customize from the menu.

2. Select your envelope and click Edit...
3. Click on the Print Field... button.

4. Choose a Print Field from the list. If you want to remove a Print Field, choose (none).
5. Click on Exit&Save to save the changes.

If you do not find a Print Field to suit your needs, you may need to create a new one. See the Advanced 
Topics section for more details.



Manual Editing 

In Enveloper 4.0, Manual Editing was called the "Preview Mode". You enter the Manual Edit Mode of 
Enveloper in several ways:

1. While customizing an envelope template using Enveloper6 Customize, click on the Manual Edit 
button.

2. While running Enveloper itself, click on the Manual Edit button.

3. Opening up an envelope template (.ENV file) using File, Open from the menu.

The mechanics are the same for any of the methods, but there are subtle differences. The primary 
difference being that changes made at run-time are not saved to the envelope template unless you 
explicitly save them with the File, Save command.

To exit Manual Edit mode, click on the Cancel or Save & Exit button of the Enveloper Manual Edit 
Toolbar.
Whenever you open an envelope template, you'll get an additional Toolbar that is available to help you 
edit your envelope.

Do not use Ctrl+F4 or double-click on the Control Menu (the hyphen box) to close the document!

Instead, choose Cancel, or Save & Exit from the Toolbar. To print the envelope, choose the Print tool 
button in the Enveloper Manual Edit Toolbar.

The Manual Edit mode allows you to view your envelope in the Page Layout view of Word for Windows. 
This not only allows you to visualize your envelope, but also reminds you how your envelope feeds into 
the printer in relation to your regular letter sized (or A4 sized) paper. Envelope borders are drawn to help 
you better visualize your envelope. 

In the Manual Edit mode, you view the layout of your envelope and reposition envelope items as 
necessary. You can move the envelope items anywhere you want on the envelope, and format the text 
items as you would like. There are really only two rules to remember when working in the Manual Edit 
mode of Enveloper:

1. Never manually delete any item from the previewed envelope. If you wish to delete an item such as a 
return address or logo, do so from the Enveloper6 Customize dialog boxes. Deleting items from the 
Manual Edit mode may cause unpredictable results when Enveloper is working with your Envelope 
template.

2. Use the Enveloper Manual Edit Toolbar buttons when formatting changes other than repositioning 
frames on the envelope. This Toolbar should appear whenever you open the envelope template.

See also:
Enveloper Manual Editing Toolbar
Formatting In Manual Edit Mode
Repositioning Items in Manual Edit Mode



Enveloper Manual Edit Toolbar 

The Enveloper Manual Edit Toolbar appears whenever you enter Manual Edit mode, or when you open an
Envelope Template. If you do not want to see the Toolbar anymore, just click on the little square to the left 
of the Toolbars title.

The Enveloper Manual Edit Toolbar contains the following buttons:

Save & Exit - Exits Manual Edit mode and save changes

If you entered this mode when using Enveloper6 Customize, then youll return to the Main Customization
Dialog Box. 

If you entered when using Enveloper at run-time, then you will be returned to the main Enveloper 
interface.

If you manually opened the envelope template by using File, Open, then the template will be saved and 
closed.

Cancel - Exits Manual Edit mode; dont save changes

If you entered this mode when using Enveloper6 Customize, then youll return to the Main Customization
Dialog Box. The changes youve made are still kept unless you click Cancel again in the Main 
Customization Dialog Box.

If you entered when using Enveloper at run-time, then you will be returned to the main Enveloper 
interface. The envelope is closed and deleted.

If you manually opened the envelope template by using File, Open, then the template will be closed and 
the changes discarded.

Print - Prints the envelope

Return Address Line 1 Font - Changes the font of the first line of the return address

Return Address Other Lines Font - Changes the font of the other lines of the return address.

Addressee Line 1 Font - Changes the font of the first line of the addressee.

Addressee Other Lines Font - Changes the font of the other lines of the addressee.

Return Address and Note Lists - Gets the Return Address and Envelope Note list for quick changes 
while in Manual Edit mode. Note that the button reads RET & NOTE LISTS, and the help text says a 
very intuitive Env RAand Note (tongue firmly planted in cheek).

Resize Logo - Resizes and repositions the logo, if any. If there are no logos, you get a warning. You 
cannot add a logo that is managed by Enveloper while in Manual Edit mode, but you can add any other 
graphics or text... you just wont be able to use the Enveloper convenience buttons to resize and 
reposition them.

Help - Jumps to the Enveloper help file.

See also:
Formatting In Manual Edit Mode
Repositioning Items in Manual Edit Mode



Formatting in Enveloper's Manual Edit Mode 

If you need to change the fonts or resize the logo, use the tool buttons in the Enveloper Manual Edit 
Toolbar. If you need to move the items in the envelope, drag its frame around or use the Format Frame 
menu command.

Actually, if you are familiar with Word Styles, do the following:

1. From the Format menu choose Style.

2. Click the Modify button

3. Click the Format button and select Frame to change the frame size and location.

Hopefully, the icons on the Enveloper Manual Edit Toolbar are straight forward. Complete words just took 
up too much space. The red line in each button image is supposed to indicate which font the button is 
supposed to affect:

Return Address, 1st line
Return Address, Other lines
Addressee, 1st line
Addressee, Other lines
Note

Note that these buttons are simply convenient interfaces to change the Font Style of the 
EnvAddressee, EnvAddresseeRest, EnvRetAddr, EnvRetAddrRest, and EnvNote styles. Sorry, 
there are still only two font styles for each address block.

The Resize Logo button on the Enveloper Manual Edit Toolbar allows you to resize your logo as in the 
Enveloper6 Customize dialog box. If your graphic is too large or small for the envelope choose this 
button to resize the logo to the necessary dimensions. Leaving one dimension blank will scale both 
dimensions equally. Choose the Reset to 100% button to reset the graphic to its original import size. 
From this dialog box, you can also choose to place the logo to the left or above the return address.

The print routine behind the Printer button on the Enveloper Manual Edit Toolbar takes a bit longer than 
normal Enveloper print. This is because Enveloper needs to remove the envelope borders before sending
the page to the printer (the borders are added when entering the Manual Edit mode).    

There's also a Toolbar button with a tool tip text "RET & NOTE LISTS". Clicking on this button brings up 
two drop-down list boxes from which you can choose to change the return address and note.

See also:
Repositioning Items in Manual Edit Mode
Enveloper Manual Editing Toolbar



Repositioning Items in Manual Edit Mode 

Enveloper's default positioning for items is usually correct for most envelopes you might want to create, 
but there are always exceptions. The elements that make up Enveloper, the addresses, the logo, and the
note can all be repositioned in the Manual Edit Mode. The following steps outline the steps to 
repositioning the addressee information:

1. From the Tools menu choose Enveloper6 Customize.

2. Select the envelope template to edit and choose the Edit button.

3. Choose the Manual Edit button.

4. Locate the addressee information and click on the address once with the mouse. This should select 
the address so that a box appears around the address.

5. Position the mouse cursor near the edge of the box so that the mouse cursor changes to a four-sided 
arrow. Now, click and drag with the mouse to reposition the addressee.

6. You have now successfully moved a framed object in the Manual Edit mode.

7. Choose the Save & Exit button from the Enveloper Manual Edit Toolbar to exit Manual Edit mode 
with your changes intact.

Note that instead of manually dragging the frame, you can also use Style from the Format menu. 
Replace step 5 above with the following:

5a. Choose Style from the Format.
5b. Highlight the style associated with the item you want to move. The style names all begin with the 

letters Env.

5c. Click on the Modify button. Click on Format button, then select Frame.

5d. Change the values in the Horizontal Position and Vertical Position boxes.

See also:
Enveloper Manual Editing Toolbar
Formatting In Manual Edit Mode



POSTNET Bar Codes 
With Enveloper, you have the option of printing bar codes, 

(called "POSTNET" codes) where the United States Postal Service would like them printed on envelopes.
Additionally, you can print the FIM A bar code,

at the top of the envelope just to the left of the stamp.

These are enabled by default. To change them:

1. From the Tools menu choose Enveloper6 Customize.

2. Click on the Settings>> button.

3. Change the "Print POSTNET Bar Code" and/or the "Print FIM A Bar Code" check boxes to suit your
liking.

These are global settings. Your envelope templates still contains the visible bar codes. They will be 
removed at run time when you print your envelopes or add an envelope to a document. 

See also:
Why Bar Codes
Are Postal Bar Codes for me?



Why Bar Codes? 

Most sorting stations of the United States Postal Service (USPS) have equipment that reads and 
analyzes bar codes. These bars are simply another representation for the digits in your bar code. 
Envelopes that are not pre-printed with bar codes are sorted manually by the United States Postal 
Service. Envelopes that have postal zip codes pre-printed on them can be sorted by sophisticated 
machinery instead of by hand. In theory, envelopes with pre-printed bar codes will arrive at their 
destination earlier than others, due to the fact that they will not need to be manually sorted. And if nothing 
else, printed bar codes make your envelopes look slick and professional while lessening the burden of 
sorting mail on the part of the USPS.

See also:
Are Postal Bar Codes for me?
DPBC
FIM A



DPBC 

The United States Postal Service recently started using the Destination Point Bar Code (DPBC). In 
addition to the Zip+4 bar code, the DPBC contains an additional set of bars that represent the last 2 digits
of your street address. You don't need to worry about it. If Enveloper and Word can find the digits, they 
will be used to generate your bar code.

See also:
FIM A
Zip Bar Code Settings
Why Bar Codes
Are Postal Bar Codes for me?



FIM A 

The FIM bar codes are place next to the stamp to give bar code readers an idea of the orientation of the 
envelope (which side is up), and what type of envelope. The FIM A is just means that there is a 
POSTNET bar code on the envelope, and that the envelope requires a stamp.

There are also FIM B and FIM C bar codes, but they 99.9% of Enveloper users will not need them. FIM C
is used for Business Reply (prepaid) envelopes, and FIM B is for reply envelopes that don't contain 
POSTNET bar codes.

See also:
DPBC
Zip Bar Code Settings
Why Bar Codes
Are Postal Bar Codes for me?



Are Postal Bar Codes For Me? 

Postal Bar codes are for anyone who meets the following criteria:

1. You need to reside in the United States and mail envelopes to others who reside in the United States 
(sorry postal codes for US residents only).

2. Own a printer with the capability of printing graphics (sorry no bar codes to daisy wheel printers).



Bar Codes, How Does Enveloper Do It? 

Well... actually, Word 6 made it much easier for us. We don't have to jump through too many hoops, since
Word for Windows now supports POSTNET bar codes using a special BARCODE field. The only thing 
Microsoft screwed up is that if your address does not contain a US zip code, the field generates "Zip code
not valid!". Imagine doing a mail merge that contains Canadian envelopes; you'd wind up with envelopes 
that contain that ugly message!

Enveloper has a workaround! We format the field with the Zip (TrueType) font, provided with WOPR. This
font has no characters defined for any of the characters in the error message, so nothing will print. 
Sooooooo... if you do see the "Zip code not valid!" note on your printed envelopes, make sure the Zip font
is installed correctly using Windows Control Panel Fonts utility.

See also:
Zip Bar Code Settings
Why Bar Codes
Are Postal Bar Codes for me?



USPS Requirements and Bar Code Position 

The USPS allows the POSTNET bar code to be located in several places on the envelope:

At the bottom of the envelope
Above the addressee
Below the addressee

Refer to Zip Bar Code Settings to learn how to set the bar code position for each of your envelope 
templates.



Advanced Topics 
This section provides more details and programming information for advanced topics. These include:

Print Fields
The best way to beat the smudgies
Accessing a Phone Book Utility
Accessing a Zip Code Utility



Print Fields 

Print fields are an advanced feature that may be best left to those who understand printer escape 
commands. Print fields are printer-specific commands that are sent directly to the printer, without any 
embellishments from Word for Windows. One use for this feature is to enable the Reverse Landscape 
mode on Hewlett Packard LaserJet III, LaserJet 4, and PostScript printer. The Reverse Landscape mode 
allows the return address to be printed at the leading edge of the envelope. This particular mode is 
automatically enabled during installation (Enveloper Installation asks which fields you want to use.)

The print fields are sent to the printer before printing any item on the envelope, so that whatever the print 
field commands the printer to do will be in effect when the rest of the envelope is printed. You can see the 
print field codes in the Manual Edit Mode by selecting the Draft font view and viewing Field Codes (Tools 
Options dialog, View tab).

To place a print field into an envelope template, do the following:

1. From the Tools menu choose Enveloper6 Customize.    

2. Select the appropriate envelope from the description list and choose the Edit button.    

3. Choose the Print Field button from the Main Customization Dialog Box. The resulting dialog will list 
the descriptions for the field codes already entered into Enveloper. There are buttons to Edit, Delete 
or create a New print fields for your envelope.    

Note: LaserJet III owners should make sure the "PCL5 Reverse Landscape" field code is the default. This
way, the appropriate print field will automatically be inserted every time you create a new envelope. To 
ensure this is the default, select the field and click the Save As Default button.



Editing or Creating Print Fields 

Editing or creating Print Fields involves two steps. You will need to supply a description for the print field 
(e.g., PCL5 Reverse Landscape) and the actual printer code itself (the printer instructions). If you were to 
view the printer code for the PCL5 Reverse Landscape description (choose the Edit button), you would 
see the following code:
print "Esc &a180P Esc &l1E"

Instead of using a Chr$(27) to indicate the Escape character, just type "Esc "; note that the trailing 
space is required. At run time, this Esc+Space is converted to Chr$(27). For more information on 
appropriate printer codes, you will need to consult your printer documentation. 



More on the PCL 

Hewlett Packard and compatible printers speak a language called PCL. A PCL5 printer code is used to 
access the Reverse Landscape mode for LaserJet III and LaserJet 4 Series printers. A PCL5 example 
sequence is as follows:
Esc &a180P

This sequence will rotate the page 180 degrees. That is, turn the page upside down. 

The print field code for "PCL5 Reverse Landscape" is a combination of two sequences: one to rotate the 
page and one to adjust the top margin:
Esc &a180P Esc &l1E

In order to make the envelope print out correctly in reverse landscape mode, you may also need to adjust 
the top margin. If you select a LaserJet III model during installation, then the top margin will be 
automatically adjusted during installation, but here is an explanation just the same:

When printing using Reverse Landscape, the printed page is shifted down by about two lines. As a result, 
the margin needs to be reset to a smaller number. On a LaserJet III, a margin of 1 line seems to do the 
job effectively and the code for that is:
Esc &l1E

which makes up the second half of the PCL5 Reverse Landscape print field.



A Note on PostScript 

In Windows 3.0, PostScript printer naturally printed in Reverse Landscape. The Windows 3.1 PostScript 
driver, however, turned things upside down, literally! The easiest fix to force Reverse Landscape by 
adding a line to your WIN.INI file. Look for the section starting with [Devicename,Port], where 
Devicename matches your printer and Port is your printer port. Add the line, LandScapeOrient=270. 
For example:
[HP LaserJet III PostScript,LPT1]
LandScapeOrient=270

Again, Enveloper Install will enter this for you if you tell it to. If you wish to do this (and it is 
recommended), then you must remove any Reverse Landscape printer codes from each of your 
envelopes:

1. From the Tools menu choose Enveloper6 Customize.

2. Choose an envelope then click the Edit button

3. In the Main Customization Dialog Box, click Print Fields.

4. Select "(none)" click on the Save as Default and then click on Use for Envelope.

5. Click Save & Exit to save the envelope.

6. Repeat steps 2 through 5 for each envelope.

If you don't wish to turn all your landscaped documents upside down, then you need to imbed some 
printer field codes. The following instructions describe the process for embedding PostScript Reverse 
Landscape codes.

This is not as easy to do for PostScript printers, since there is not a simple escape code to accomplish 
this. The exact code will have to depend on the page size you're using to create your envelopes and your 
printer resolution. If you do not use the Fit Page To Envelope mode, you can use the provided Print 
Fields to perform Reverse Landscape.

Some examples and explanations are provided on the following page.

For US users using letter-sized paper for envelopes, the required code is:
{print "11 .52 sub 300 mul 8.5 .5 sub 300 mul translate 180 rotate "}

Let's see how we arrived at these numbers. Use the following figure as a guide. The dimensions of the 
letter-sized paper is 11.0" x 8.5". That's where the "11" and "8.5" in the code comes from. The 300 is the 
resolution of the printer in dots per inch (dpi). Some newer printers are now coming out with 600 or even 
800 dpi. Those users may need to replace the 300 with the appropriate values for their printers.

The margins along the long dimension are 0.27" and 0.25". Their sum is:
0.27 + 0.25 = 0.52 inches

So we need to move the x origin by:
11.0 - 0.52 = 10.48 inches

Both margins along the short dimension are 0.25", so we move the y origin by:
8.5 - 0.5 = 8.0 inches

If you use any other page sizes (especially if you use "Fit Page to Envelope"), you need to modify these 
numbers. Simply replace the "11" by the long dimension of your page and "8.5" by the short dimension of 
your page, expressed in inches.



For European users, using A4 sized paper (29.7cm x 21.0 cm), the Reverse Landscape code is:
{print "29.7 2.54 div .52 sub 300 mul 21 2.54 div .5 sub 300 mul translate 
180 rotate "}

Here we've added the conversion from centimeters to inches by dividing the page dimensions by 2.54.

If you use any other page sizes (especially if you use "Fit Page to Envelope"), you need to modify these 
numbers. Simply replace the "29.7" by the long dimension of your page and "21" by the short dimension 
of your page, expressed in centimeters.

Additionally, you may need to change "300" to match the resolution of your printer.



The best way yet to beat the smudgies 

There are a couple of ways to eliminate smudging on your envelopes, each method is described in detail 
below. 

1. If you indicated that you are using a Hewlett Packard Series III printer during installation, Enveloper 
will print your envelopes in reverse landscape mode. When an envelope travels through your printer, 
it develops something called "flutter", minuscule movement that causes smudging. If you use reverse 
landscape (thus printing the return address on the leading edge of the envelope), there is less 
opportunity for "flutter" to develop. 

2. Flip down the exit tray, if your printer has one. The exit tray allows the paper to exit without curling 
back around.

3. You can buy envelopes made especially for laser printers. These envelopes are characterized by 
sharp, sharp folds and minimal "bulge" on the seams. Bulges cause minute shifts in the envelope as it
feeds through the printer, which in turn cause smudges.    

4. One final way to defeat the "smudgies" on laser printer envelopes is to use a "Enveloper Cheat 
Sheet". This method is ideal for LaserJet series II printers. To make an "Enveloper Cheat Sheet", do 
the following:

5. Take a sheet of heavy cover stock about 30 to 40 lb. For the standard Com 10 envelopes, cut a piece 
of cover stock exactly four and one-sixteenth inches wide and about eight and a half inches long. A 
properly trimmed "Enveloper Cheat Sheet" should fit snugly inside your envelopes in the "short" 
direction, but have an inch or so of play in the "long" direction. All registered users should be getting a
cheat sheet.

6. Now the next time you print envelopes, flip out the output or exit tray, if you have one. This will keep 
the envelope from making that last tight turn before landing in the output bin. Tuck your "Enveloper 
Cheat Sheet" under the flap of the envelope so that the Cheat Sheet is up against the return-address 
edge of the envelope (that is the left edge as you look at the envelope's printed side). Finally, feed the
envelope through as you normally would. 

7. Notes: The "Enveloper Cheat Sheet" works on laser printers that are printing in the normal landscape
mode. If you have a Series III LaserJet printer, you don't need a Cheat Sheet because Enveloper 
automatically is set to print in the reverse landscape mode available on the LaserJet III Series 
printers. Also the Cheat Sheet doesn't improve the output when printing to a HP DeskJet printer, but it
really shouldn't be needed with the DeskJet.



Accessing a Phone Book Utility 

By default, the PhoneBook button in Enveloper's run-time dialog box hooks into the WOPR Address 
Book utility to look up an address. If you already have another Phone Book or PIM utility, you can easily 
customize Enveloper to use your utility instead! You just have to know how to coax your Phone Book 
utility to get the results back to you via a function call. Most of these utilities sport a Dynamic Data 
Exchange (DDE) or Dynamic Link Library (DLL) interface to other Windows applications. You need to 
consult their documentation to find out how to do it.

Once you figure that out, you just need to edit one function in Enveloper to complete the hook. This 
GetPhoneBook$() function is located in the EnvHooks macro of the ENVR6.DOT template in your 
WINWORD\STARTUP directory. The function has the following declaration:

Function GetPhoneBook$(addr$)
It takes a single string argument and returns another string. Typically, the input argument string is a name 
or partial address; you feed that string to your Phone Book utility to get the full address. Just use that full 
address as the return value of the function, and Enveloper will use it to fill in the Addressee TextBox.

To edit the macro, use the following procedure:

1. Open the WINWORD\STARTUP\ENVR6.DOT document. Note that you need to adjust the path to 
match your setup.

2. From the Tools menu choose Macro. Make sure the "Macros Available In" list box reads "Envr6.dot
(template)".

3. Highlight EnvHooks in the Macro Name list, and click the Edit button.

4. Scroll down to the GetPhoneBook$() function and make your changes. Use the original macro as 
an example.

5. When you're done, choose Save All from the File menu.

Obviously, you have to be familiar with WordBasic to perform this procedure.

We'll try our best to help you make it work, but the details are very much dependent on your Phone Book 
utility or PIM. Try to ask their Tech Support to supply you with a WordBasic macro that does the same 
thing as GetPhoneBook$(), then just copy it into the EnvHooks macro!



Accessing a Zip Code Utility 

The procedure for creating a hook to your Zip Code Utility is very much the same as the procedure for 
creating a hook to your Phone Book Utility.

Unfortunately, we were not able to find a feasible Zip Code utility that makes this easy. The reasonably-
cost ones did not provide adequate (any) Dynamic Data Exchange (DDE) or Dynamic Link Library (DLL) 
support, and the ones that do cost several hundred dollars....at least!

We do, however, anticipate these Zip Code utilities to get cheaper and provide better inter-application 
support during the life-time of WOPR 6, so we've provided the hook. If you already have a Zip Code utility
that provides DDE or DLL support, you can easily hook it into Enveloper!

You just need to edit one function in Enveloper to complete the hook. This FindZip$() function is 
located in the EnvHooks macro of the ENVR6.DOT template in your WINWORD\STARTUP directory. The 
function has the following declaration:
Function FindZip$(addr$)

It takes a single string argument and returns another string. Typically, the input argument string is a partial
address; you feed that string to your Zip Code utility to get the full address with the Zip +4 code. Just use 
that full address as the return value of the function, and Enveloper will use it to fill in the Addressee 
TextBox.

To edit the macro, use the following procedure:

1. Open the WINWORD\STARTUP\ENVR6.DOT document. Note that you need to adjust the path to 
match your setup.

2. From the Tools menu choose Macro. Make sure the "Macros Available In" list box reads "Envr6.dot
(template)".

3. Highlight EnvHooks in the Macro Name list, and click the Edit button.

4. Scroll down to the FindZip$() function and make your changes.

5. When you're done, choose Save All from the File menu.

Obviously, you have to be familiar with WordBasic to perform this procedure.

We'll try our best to help you make it work, but the details are very much dependent on your Zip Code 
utility. Try to ask their Tech Support to supply you with a WordBasic macro that does the same thing as 
FindZip$(), then just copy it into the EnvHooks macro!



Common Questions 
This section includes some commonly asked questions and answers.

Multiple Return Addresses
Logo Position
Non-Breaking Hyphen
Blank PostScript Envelopes
Upside-Down Envelope
Envelope Feeder
Margin Errors
Cut-Off Bar Codes
Wrong Addressee PositionUpside-Down Logo



Q&A Multiple Return Addresses 

Q. I have two return addresses that I normally use. Having to switch between them is a pain, since 
editing envelope templates is so slow. Is there a way to switch my return addresses dynamically at 
run-time?

A. There is, but you have to change the way you think about envelopes. The way to get what you want is
to create two envelope templates, each with its own return address. You can think of these as 
computer models of preprinted envelopes. You can customize each one to have different fonts also. 
At run-time, simply choose the envelope template that corresponds to the return address you want. 



Q&A Logo Position 

Q. Enveloper seems to have its own idea of where my logos go. Is there any way I can change that?

A. Yes. You can reposition the logo, or any item for that matter, in the Manual Edit mode. Each envelope 
item is contained in a frame. Just move the cursor to the edge of the frame until it turns to a four-
headed arrow. Then simply drag-and-drop the frame to a new location. Be forewarned, however, that 
you may need to reposition the logo if you change its size or replace it.

Each envelope item also belongs to a Style. You can move each item by choosing Style from the 
Format menu. Choose one of the following styles:

EnvLogo
EnvNote
EnvAddressee
EnvRetAddr

Now, click the Modify button. Click on the Format button and select Frame. Change the position and 
size of the frame to your liking.



Q&A Non-Breaking Hyphen 

Q. Where did my NON-Breaking Hyphen go???

A. Well, Microsoft's Addressee Grab method apparently swallows nonbreaking hyphens 
(Ctrl+Shift+Hyphen). You need to use Enveloper's SmartGrab. From the Tools menu choose 
Enveloper6 Customize, click on the Settings>> button and select SmartGrab. Click OK. Run 
Enveloper again, and you should see your hyphen.



Q&A Blank PostScript Envelopes 

Q. I have a PostScript printer. Envelopes look OK in Preview mode, but nothing prints. What's wrong?

A. You probably installed PCL5 Reverse Landscape codes rather than the PostScript Reverse 
Landscape codes. To fix this problem, edit your envelope templates by choosing Enveloper6 
Customize from the Tools menu. Highlight the envelope you want to fix and click Edit. Click the 
Print Field button to see if there are any imbedded print fields. To make sure, select "(none)". Click 
the Save as Default button, then the Save & Exit button. 

Now you need to make a small change to your WIN.INI. Jump to the Upside-Down Envelopes topic 
for information on this WIN.INI change.



Q&A Upside-Down Envelope 

Q. I have a PostScript printer and just upgraded to Windows 3.1. Now all my envelopes are printing 
upside down. What happened?

A. Microsoft changed the PostScript printer driver to print "Normal Landscape" in Windows 3.1. The 
easiest way to fix it is to add a line in your WIN.INI file. 

Open your WIN.INI file with an ASCII text editor (make a backup first!). Look for the section starting 
with [Devicename,Port], where Devicename matches your printer and Port is your printer port. Add 
the line, LandScapeOrient=270. For example:

[HP LaserJet III PostScript,LPT1]
LandScapeOrient=270



Q&A Envelope Feeder 

Q. I have an envelope feeder for my laser printer, but the printer driver keeps complaining that it can only
print envelopes and refuses to print.?

A. Most printer drivers are very picky when you use the envelope feeder. For example, the driver may 
not allow you to send a letter-size page to the printer's envelope feeder, even though the envelope 
image is placed correctly. To remedy this situation, you need to use the Fit Page to Envelope setting 
in Enveloper.

To make the change, choose Enveloper6 Customize from the Tools menu. Select your envelope 
and click Edit. Click on Printer & Zip Settings and then choose the "Fit Page to Envelope" check 
box in the Feed Method section. Click on <<Back, then click TestPrint to try it out. Click on Save & 
Exit to save all changes.



Q&A Margin Errors 

Q. I keep getting Margins are set outside printable area errors, but the envelope prints fine. How can I 
get rid of these messages?

A. You need to adjust the standard margins that Enveloper uses for its envelopes. Choose Enveloper6 
Customize from the Tools menu. Select your envelope and click the Edit button. Click on Printer & 
Zip Settings, and make changes to the margins. To find the proper minimum margins for your printer,
you can use the WOPRMinMargins utility macro. Follow the directions in the Minimum Margins topic 
to learn how this is done.



Q&A Cut-Off Bar Codes 

Q. I'm using an envelope printing format that aligns the envelope at the bottom edge of the page. The 
problem is that the bar codes are getting cut off. I tried moving it, but it always ends up in the same 
place. How can I change this?

A. To protect against accidental moves, Enveloper resets the bar code position whenever you exit 
Manual Edit mode. This is done because the bar code has to be in a fairly precise location, unlike the 
other items on the envelope. To really move the bar codes, you need to edit your envelope template 
with Enveloper6 Customize from the Tools menu. Choose Printer & Zip Settings and change the 
bar code location. You may want to just use the "Above Addressee" setting to avoid the problem 
altogether. See the USPS Requirements and Bar Code Position topic for a more detailed explanation.

See also:
POSTNET Bar Code Requirements



Q&A Wrong Addressee Position 

Q. When I print an envelope, the addressee prints near the top, where the return address should be. 
What went wrong?

A. You probably tried to manually delete the return address when in the Manual Edit mode. This is not 
allowed, since it could mess up the bookmarks that Enveloper depends on for proper operation. If 
you don't need a return address, use the (blank) return address option when you edit the envelope 
template.

There is no fix for this problem, you need to create your envelope template again.



Q&A Upside-Down Logo 

Q. How come my Logo is printing upside-down, and completely off the envelope? When I feed a letter-
sized paper through instead of the envelope, the logo is at the bottom edge of the piece of paper.

A. You must be using a print field to turn on Reverse Landscape. The problem is that the Logo is printing
before the Print Field, so that the printer doesn't know the you want to print Reverse Landscape until 
after the Logo has printed already.

To fix this, go into Manual Edit mode and drag the Logo down a little and to the right a little. Hopefully,
this will be enough to make the Print Field print first. Click the Printer Tool in the floating Enveloper 
Manual Edit Toolbar to test it.



Registration Information
Enveloper is just a small part of Woody's Office POWER Pack product or WOPR for short. WOPR 
(pronounced as whopper) includes a collection of Word for Windows macros and add-ins such as Two by 
Four (2 X 4), TBEdit, File Manager, Stellar Spellar and File New. "WOPR 6.0" is brought to you by 
Pinecliffe International and can be yours for the low, low price of $49.95 plus a $4.50 shipping and 
handling charge ($9.50 outside the USA). Registered users of WOPR 2.0 can update to WOPR 6.0 for 
$24.95.

Benefits for registering the WOPR product include the following:

A diskette with the latest versions of the WOPR 6.0 macros and add-ins without any pesky "nag 
screens".

Getting Started Newsletter

On-disk User's Manual.

Enveloper cheat sheet to keep envelopes from wrinkling.

Full source code for WordBasic routines.

Product Support via CompuServe (GO WOPR) or the telephone (314 965-5630).

Discounts on autographed books from WOPR contributors Woody Leonhard, Vince Chen, Lee 
Hudspeth, Scott Krueger and Jim Lee.

Offbeat WOPR goodies catalog offering unique WOPR baseball caps and our WOPR Power Putty hand
exerciser.

Discounts on other fine Word for Windows add-ons, including PRIME, WinBreak PRO, FileWare and 
others.

Our internationally famous guarantee: If WOPR ever fails to live up to your expectations -- doesnt 
matter what you expected, or why -- simply return it to us and tell us how much you paid. You will 
received a full refund, immediately. Period.

and most importantly, our sincere thanks for making all of this possible.

To order WOPR call 1-800-659-4696 or 1-314-965-5630 if you reside outside of the United States.

Site licenses and discounts for multiple product purchases (i.e. 10+ units) are available for WOPR 6.0. 
Call one of the above phone numbers for more information.




